Cross-Site Scripting (XSS) in PAN-OS Management Web Interface (PAN-SA-2019-0002)

Last revised: 01/23/2019

Summary

A Cross-Site Scripting (XSS) vulnerability exists in the PAN-OS Management Web Interface. (Ref. # PAN-107262; CVE-2019-1566)

Severity: High

Successful exploitation of this issue may allow an unauthenticated attacker to inject arbitrary JavaScript or HTML.

Products Affected

PAN-OS 7.1.21 and earlier, PAN-OS 8.0.14 and earlier, and PAN-OS 8.1.5 and earlier.

Available Updates

PAN-OS 7.1.22 and later, PAN-OS 8.0.15 and later, and PAN-OS 8.1.6 and later.

Workarounds and Mitigations

This issue affects the web-based management interface of PAN-OS and is strongly mitigated by following best practices for securing the PAN-OS management interface. Our best practices guidelines reduce the exposure of the management interface to potential attackers. Please review the Best Practices for Securing Administrative Access in the PAN-OS 8.1 technical documentation, available at: https://www.paloaltonetworks.com/documentation/81/pan-os/pan-os/getting-started/best-practices-for-securing-administrative-access.

Acknowledgements

Palo Alto Networks would like to thank Purplemet Security for reporting this issue.