ROBOT attack against PAN-OS (PAN-SA-2017-0032)

Last revised: 03/13/2018


ROBOT is an attack that affects the TLS RSA key exchange and could lead to decryption of captured sessions if the TLS server originally serving said captured session is still alive, vulnerable and using the same private key. (PAN-89936 / CVE-2017-17841)

Severity: High

While SSL Decryption and GlobalProtect are susceptible to this issue, PAN-OS can be protected with use of content update 757, and further mitigated through the configuration changes described below under "Workarounds and Mitigations".

Products Affected

PAN-OS 6.1.19 and earlier, PAN-OS 7.1.14 and earlier, PAN-OS 8.0.6-h3 and earlier

Available Updates

PAN-OS 6.1.20 and later, PAN-OS 7.1.15 and later, PAN-OS 8.0.7 and later.

Workarounds and Mitigations

Customers running PAN-OS 7.1 or later can configure their SSL Decryption profiles to disable RSA. If the GlobalProtect server certificate is using RSA, customers running PAN-OS 7.1 or later can opt to replace this certificate with one implementing the Elliptic Curve DSA algorithm as a safer alternative. In addition, Palo Alto Networks has released content update 757 which includes a vulnerability signature ("TLS Network Security Protocol Information Disclosure Vulnerability - ROBOT", #38407) that can be used as an interim mitigation to protect PAN-OS devices until the software is upgraded. For complete protection, signature #38407 must be applied upstream from any interfaces implementing SSL Decryption, or hosting a GlobalProtect portal or a GlobalProtect gateway.