Command Injection Vulnerability (PAN-SA-2012-0009)

Last revised: 04/27/2012


A vulnerability exists whereby an authenticated user can inject arbitrary shell commands using the device management command line interface. (Ref #33080)

Severity: High

This vulnerability can result in arbitrary command execution, and can result in total compromise of the device.

Products Affected

PAN-OS 4.0.7 and earlier. PAN-OS 3.0.x is not affected.

Available Updates

PAN-OS 4.0.8 and later.

Workarounds and Mitigations

This issue affects the management interface of the device. Security appliance management best practices dictate that the management interface be isolated and strictly limited only to security administration personnel.