Command Injection Vulnerability (PAN-SA-2012-0002)

Last revised: 04/27/2012

Summary

A vulnerability exists whereby an authenticated user can inject arbitrary shell commands using the device management command line interface. (Ref #31116)

Severity: High

This vulnerability can result in arbitrary command execution, and can result in total compromise of the device. The attacker must still be an authenticated administrator of the device.

Products Affected

PAN-OS 4.0.4 and earlier; PAN-OS 3.1.9 and earlier.

Available Updates

PAN-OS 4.0.5 and later; PAN-OS 3.1.10 and later.

Workarounds and Mitigations

This issue affects the management interface of the device. Security appliance management best practices dictate that the management interface be isolated and strictly limited only to security administration personnel.

Acknowledgements

-